All Options Greyed Out in TFS Admin Tool 2.1 once connected to TFS Server

Topics: For TFSAdmin Developers, For TFSAdmin Users, TFSAdmin FAQ
Apr 20, 2011 at 3:27 PM

Hi,

I have just installed TFS Admin Tool 2.1. I have installed TFS 2010 and TFS 2010 SP1. I am also the administrator for TFS 2010. When I enter TFS Admin Tool 2.1 I am able to connect to my TFS server and collection but all options to add users, edit users, delete users etc. are greyed out? I have no idea why, I have tried this from my client machine and even from the TFS server and I get the same result. The tool is completely unusable?

Thanks

Stephen 

Jul 16, 2012 at 5:39 PM

I too am seeing this issue.

 

Some extra info:  We just upgraded from TFS 2005 to TFS 2010.  VS2010 is able to connect to TFS with no issues.  We are able to hook up the SharePoint portals and get bidirectional communications between the two systems.

When I connect to a project in TFS Admin Tool 2.1, even after clicking on the individual Team Project, all of the buttons in the right pane stay greyed out and nothing comes up in the area below them.  The only buttons that are ever active are Connect, Disconnect and About.

Is there some sort of issue with this tool being able to handle projects that were converted from older versions?

Oct 17, 2012 at 3:14 PM

Same here. Did anyone got a reply on how to solve this issue?

Oct 17, 2012 at 4:36 PM

In my case, it would seem the issue was rather simple.  Once connected, i had to double click on the collection of interest on the left side in order to get the options to show up on the right.  Seems like a little bit of a UI issue there that could be resolved by moving that event to a single click, though there might be a good reason to do it on the double.

Oct 17, 2012 at 5:01 PM

That worked, thanks. I would have never have guessed...