Uninstalling 1.2 If You've Already Upgraded Team Explorer to 2008?

Topics: For TFSAdmin Developers
Feb 13, 2008 at 2:00 PM
I have TFS Admin 1.2 installed on my TFS Server. I then upgraded to TFS2008, now want to install 1.3.

The 1.3 installer says I need to uninstall the older version...

When I try to uninstall 1.2 I get an error that Team Explorer is not installed. (And I've confirmed that TE2008 is installed).


Any suggestions for uninstalling 1.2?

Thanks,
Greg
Feb 14, 2008 at 12:57 AM
I have the same problem.

Thanks Philip
Feb 19, 2008 at 4:25 PM
Edited Feb 19, 2008 at 4:28 PM
I'm having the same problem as well. If I try to install the new version, it tells me I have to uninstall the old version first. When I try to uninstall the old one, I'm told Team Explorer is not installed. Some help would be appreciated. Thanks!

Melissa

Actually, I just fixed it! Click the link that says "Click here for support information." There's a button in the resulting dialog box labeled "Repair". Click that button, then close this dialog box and uninstall from the Add/Remove Programs list. It will work now.
Feb 20, 2008 at 4:47 PM


mskenny wrote:
I'm having the same problem as well. If I try to install the new version, it tells me I have to uninstall the old version first. When I try to uninstall the old one, I'm told Team Explorer is not installed. Some help would be appreciated. Thanks!

Melissa

Actually, I just fixed it! Click the link that says "Click here for support information." There's a button in the resulting dialog box labeled "Repair". Click that button, then close this dialog box and uninstall from the Add/Remove Programs list. It will work now.


Nice... But I just tried that and it didn't work for me... sigh
On the TFS Admin Support Info dialog, I tried repair and from their I still get the same "Team Explorer is not installed" error dialog... sigh.

I'm going to try a MSIZap or like MSI Cleaner tool (as soon as I find a download for it)
Feb 20, 2008 at 5:02 PM
Edited Feb 20, 2008 at 5:16 PM
Okay, here's how I was able to uninstall it (and get 1.3 installed and working).
  1. I downloaded and installed the Windows Installer Cleanup Utility (aka MSICUU2) from http://support.microsoft.com/kb/290301
  2. I launched the "Windows Install Clean Up" from the Start menu
  3. Scrolled through the list until I found TFS Administration Tool 1.2.0
  4. Selected it and clicked on the Remove button.
  5. Then I was able to install 1.3, but...
  6. When I tried to launch 1.3, the files for 1.2 were still there (so I got an error that it couldn't find the Team Explorer v8 files...).
  7. I then uninstalled 1.3 (which removed all the 1.2 files, start menu items, etc)
  8. I then re-installed 1.3

NOW it works! Yeah!

If I had manually deleted the files after step #4, I'd probably been able to install 1.3 and run it the first time through (as the Windows Installer Clean Up utility ONLY cleans up/removes stuff from the Windows Installer database and DOES NOT actually uninstall a product... )

Still I hope this helps,
Greg