Unable to Commit SharePoint Changes

Oct 15, 2012 at 7:04 PM

All pending changes to SharePoint fail with:

It will successfully commit changes to both TFS and the Reporting Services. This was working last week so I'm note sure what changed.  Saw another thread noting this problem but no resolution.  Any idea what could be wrong.  I'm not even sure what SharePoint services to restart to try and resolve.



10/15/2012 2:02:32 PM: Button clicked: Pending Changes COMMIT10/15/2012 2:02:32 PM: Exception occurred                       Type: System.Web.Services.Protocols.SoapException                       Message: Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.                       InnerException: -                       Source: System.Web.Services                       Target: System.Object[] ReadResponse(System.Web.Services.Protocols.SoapClientMessage, System.Net.WebResponse, System.IO.Stream, Boolean)                       Stacktrace:    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)   at TFSAdministrationTool.Proxy.SharePoint.UserGroup.AddUserToRole(String roleName, String userName, String userLoginName, String userEmail, String userNotes) in D:\Work\TFSAdmin\Main\src\TFSAdministrationTool.Proxy\Web References\SharePoint\Reference.cs:line 553   at TFSAdministrationTool.Proxy.SharePointProxy.AddUserToRole(String userName, String role, String displayName, String email, String description) in D:\Work\TFSAdmin\Main\src\TFSAdministrationTool.Proxy\SharePointProxy.cs:line 83   at TFSAdministrationTool.Proxy.TeamFoundationServerProxy.SharePointAddUserToRole(String teamProject, String userName, String role) in D:\Work\TFSAdmin\Main\src\TFSAdministrationTool.Proxy\TeamFoundationServerProxy.cs:line 657   at TFSAdministrationTool.Controllers.MainController.OnCommitChange(PendingChange pc) in D:\Work\TFSAdmin\Main\src\TFSAdministrationTool\Controllers\MainController.cs:line 109

Nov 14, 2012 at 9:13 PM

Ok, I figured this one out.  It had to do with how permissions were being managed by individual SharePoint project portals. It worked for some of my projects and not others.  I thought something changed that fixed it, but oh no. Some of my SharePoint project have permissions managed at the parent level and inherit.  This tool does not like that.  You can remove the inheritance by going to the Visual Studio Team Explorer. Right click and select "Show project portal".  Go all the way to the right and select site-actions-> site-settings.  In advance permission, select action-> edit permissions. It will throw up a dialog warning about changing permissions.  In my case I could ignore. Judge for yourself.  All of the user that were at the parent level will now have the parent level permissions at the site level.  You can now use the admin tool to adjust.  It will not show everyone as it seem like the display is driven from the TFS project level.  You can remove the unnecessary folks at the sharepoint advance permissions if necessary.