Cannot Connect to TFS 2010 RTM

Topics: For TFSAdmin Users
Jul 22, 2010 at 3:52 PM

When i try to connect to TFS 2010 RTM I get the TF31002: Unable to connect to this Team Foundation Server: vstfs2010a.xxx.dev
Team Foundation Server Url: http://vstfs2010a.xxx.dev:8080

I have tried to install TFS Admin tool 2.0, 2008 team explorer + sp1 + going forward update and team explorer 2010 on both a client (win7 x64) and the TFS server (2008 R2 x64)

I can connect just fine from the 2010 Team Explorer
I can NOT connected from 2008 Team Explorer or TFS Admin tool 2.0

The behaviour is the same on the client and the server.

The TFS Admin tool log file contains:
22-07-2010 16:24:59: TFS Admin Tool application started
22-07-2010 16:25:11: Button clicked: Server Explorer CONNECT

I have tried using this as the TFS Server name:
vstfs2010.xxx.dev
vstfs2010.xxx.dev/tfs
vstfs2010.xxx.dev/tfs/DefaultCollection

That makes no difference.

Please note that the TFS server is a test TFS server I am using to figure out how to upgrade from 2008. I have restored the databases and got everything up and running but i have NOT changed the TFS Server GUID. Not sure if that is the issue.

Please advice

Tony

Jul 22, 2010 at 10:15 PM

Hello Tony,

When "cloning" an existing Team Foundation Server 2008 you need to make sure that you change the instance id otherwise you might be running into the issue described in this blog post: http://blogs.msdn.com/b/buckh/archive/2006/10/17/creating-a-new-server-from-an-old-one-beware-of-the-instanceid.aspx. Before you continue using the test server I would highly recommend that you change the instance id as described in the blog post.

In order to connect from Team Explorer 2008 to a Team Foundation Server 2010 you need to use the Url. In your case you can connect to the default collection using either http://vstfs2010.xxx.dev:8080/tfs or http://vstfs2010.xxx.dev:8080/tfs/DefaultCollection. In case the forward compatibility update is installed, you will notice that when you enter "http://" in the server name field, all other fields are greyed out. If that is not the case than the forward compatibility update did not install correctly. You can resolve that by uninstallig it, performing a repair on Visual Studio, and installing the patch again.

Please try to enter the Url in the server name field and let me know how it goes. Thanks, Ladislau  

Jul 27, 2010 at 2:50 PM

Hi Iszomoru,

I will perform a new test upgrade and change the instance id and test again. Changing the instance id after configuring sharepoint and lab management was not a good idea. The forward compatibility update seems to have been installed correctly.

I will report back to you in a few days. Thank you for your help

/tony

 

 

Aug 11, 2010 at 10:10 AM

After reinstalling TFS and perform a new upgrade everything is working just fine.

Aug 16, 2010 at 4:32 PM
When will a version that works with Team Explorer 2010 assemblies available?
Aug 19, 2010 at 3:49 AM

I'm also interested in learning if this will work with the Team Explorer 2010 assemblies.

Aug 26, 2010 at 3:43 PM

@Tony: Glad to hear that after performing a new upgrade everything is working as expected.

@hippycraig, @Allen: I am currently finalizing the work on the new version of the TFS Administration Tool which would use the Team Foundation Server 2010 object model. Keep an eye on the project site for updates.

Thanks, Ladislau

Aug 30, 2010 at 4:36 PM

Great to hear that it's being finalized. Can't wait to take a look at the tool and crack open the source and figuring out how you've been working with 2010. Please keep us posted.

Sep 5, 2010 at 9:20 AM

@Allen: The near final source code has already b een integrated into Main so you can download it and take a look already if you wish.

Ladislau

Sep 20, 2010 at 11:54 AM

I will have to take a look. I was hoping for an MSI but code is code.

Sep 20, 2010 at 12:55 PM

I will do my best to post the MSI as soon as possible.

Thanks, Ladislau

Sep 20, 2010 at 7:58 PM

I am having problems getting the Path property into the connection string.  The Add Server connection window only allows for port number and http/s radio buttons.  How do I get the path into the connection URL?

Sep 27, 2010 at 3:35 PM

Hi All,

I have a TFS2010 server, and a client running Win7/x64. I have VS2008 with the forward compatibility patch, VS2010 and the TFS Administration Tool 2.0.

I can connect to my server from both the VS2008 team explorere and via the Administration Tool. However, when I connect with Administration Tool, all my 'Add user', 'edit user', 'delete user' and 'import users' buttons are disabled.

 

Any ideas?